package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[({[\w\s\]})]+`)
var str = `({[TEST CODE AND STUFF]})`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}