const regex = /([<]textarea.*[<\/textarea][>])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([<]textarea.*[<\\\/textarea][>])', 'g')
const str = `<p>
<textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">
<p>5051950</p>
</textarea>
</p>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5"></textarea></p>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5"></textarea></p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}