$re = '/(?<=^|,)hardrock(?=,|$)/m';
$str = 'hardrock,victor,alpha,matt,hardrock-victor,ben,hardrock,rocker,ranzian,hardrock
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);