$re = '/[0-9.]()/';
$str = 'I play StarMade 0.199.429';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;