import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^|[A-Z]?\\s)(.\\d{1,2}[\"+-]?\\s.*?)(?=MS\\D\\D.\\d|.\\d\\D\\D\\D\\D\\D|.\\d\\D\\D.\\d|AW\\D\\D\\D\\D\\D|AW\\D\\D.\\d)(MS\\D\\D.\\d|.\\d\\D\\D\\D\\D\\D|.\\d\\D\\D.\\d|AW\\D\\D\\D\\D\\D|AW\\D\\D.\\d)";
final String string = "14+ Ywu&rb12AiBNL\n"
+ "18- vu20BEBNL\n"
+ "^15+ vwu&ob12Ai18C\n"
+ "C C 20\" &dg15BE23C\n"
+ "19- vu20AQ 5\n"
+ "S S 20\" w16BE26S\n"
+ "24 MSBE 6\n"
+ "N 22- MSBE15N \n"
+ "G22 AWAiRBa\n"
+ ".26\" AWFE 8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}