$re = '/(\­|)/i';
$str = 'My text will be hyphened';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);