package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}\/\d{2}\/\d{4}$`)
var str = `01/01/1900
001011900
01/01/222
01/01/22233`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}