using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[.?!]+\K\s+(?=[A-Z])";
string input = @"Fry me a Beaver. Fry me a Beaver! Fry me a Beaver? Fry me Beaver no. 4?! Fry me many Beavers... End";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}