# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:4[0-9]{12}(?:[0-9]{3})?|5[1-5][0-9]{14}|3[47][0-9]{13}|3(?:0[0-5]|[68][0-9])[0-9]{11}|6(?:011|5[0-9]{2})[0-9]{12}|(?:2131|1800|35\d{3})\d{11})$"
test_str = ("# American Express\n"
"378282246310005\n"
"371449635398431\n"
"# American Express Corporate\n"
"378734493671000\n"
"# Diners Club\n"
"30569309025904\n"
"38520000023237\n"
"# Discover\n"
"6011111111111117\n"
"6011000990139424\n"
"# JCB\n"
"3530111333300000\n"
"3566002020360505\n"
"# MasterCard\n"
"5555555555554444\n"
"5105105105105100\n"
"# Visa\n"
"4111111111111111\n"
"4012888888881881\n"
"4222222222222\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.