$re = '/^127\.\d{1,3}\.\d{1,3}\.\d{1,3}(\:\d+)?$/m';
$str = '127.1.1.1:4000
127.12.12.12
127.0.0.2:599595
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);