$re = '/(\S.*? [a-z]+[.?!])(?=\s+|$)/m';
$str = 'Bill attended the meeting and provide some valuable input. John was at the meeting but said nothing. Mr. Smith cound not attend. A. B. Butler presented the financial results and took questions. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);