$re = '/"(<[^>]*%>)/';
$str = '<img src="<IMAGE%>" width="50" height="35">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);