$re = '~[^/]+\.css~';
$str = 'http://domain.net/jitwp/wp-content/themes/strappress/style.css?ver=3.1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);