// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:10|[0-9](?:\[.,][0-9]?[1-9])?)$").unwrap();
let string = "0
10
0.5
5.9
0.25
5.75
3.03
5,5
5.0
3.333
11
10.5
3.30
5.50";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}