package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[.*?\](*SKIP)(*F)|@(\w+)`)
var str = `Hello @alice and [ @bob](...)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}