$re = '/Page (?<CurrentPage>\d+) of (?<TotalPage>\d+) \w+ \w+ (?<Code>.*?) (?<Date>\d{2}\/\d{2}\/\d{4})/';
$str = 'Unit Code : Billing Period : Billing Date : Due Date : Total Amount Due : STATEMENT OF ACCOUNT Page No.: Page 1 of 2 July 2016 1S-D-0303 07/07/2016 JOHN DOE Unit 303D, Building name, CITY NAME
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);