const regex = /S304JB0...(?<Total1>[\d]+).(?<Total2>[\d]+).(?<Total3>[\d]+).(?<Total4>[\d]+).(?<Total5>[\d]+).(?<Total6>[\d]+).(?<Total7>[\d]+)(?=.*?R03(?<Row3>[\d]+))(?=.*?R04(?<Row4>[\d]+))(?=.*?R15(?<Row15>[\d]+))/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('S304JB0...(?<Total1>[\\d]+).(?<Total2>[\\d]+).(?<Total3>[\\d]+).(?<Total4>[\\d]+).(?<Total5>[\\d]+).(?<Total6>[\\d]+).(?<Total7>[\\d]+)(?=.*?R03(?<Row3>[\\d]+))(?=.*?R04(?<Row4>[\\d]+))(?=.*?R15(?<Row15>[\\d]+))', 'i')
const str = `12*000000000**S304JB01811*8*0*8*4*4*34R0332R152~~~`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}