$re = '/^(movie|tv) (.*) (?<=season )([0-9 ]+)/im';
$str = 'tv game of thrones season 1 2 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);