package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(aaa+b)*`)
var str = `aaaab
aaaaaabaaab`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}