$re = '/\w+-\w+/';
$str = '[3-431 a4-2 4-13 ]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);