package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi),`)
var str = `Get index of this comma, but (not this , comma). Get other commas like , or ,or, 1,1 2 ,2.
(not this ,) BUT (get index of this comma, if more than 20 characters are inside the parentheses)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}