const regex = /^((https|http):\/\/)?(www\.)?([\w-]{2,}\.[\w-]{2,3}\.[\w-]{2,3}|[\w-]{2,}\.[\w-]{2,3})(\/[a-z0-9]+(\.(php|html|asp|aspx))?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((https|http):\\\/\\\/)?(www\\.)?([\\w-]{2,}\\.[\\w-]{2,3}\\.[\\w-]{2,3}|[\\w-]{2,}\\.[\\w-]{2,3})(\\\/[a-z0-9]+(\\.(php|html|asp|aspx))?)?$', 'gm')
const str = `https://www.page.com/about.php
https://www.page.com/about
https://www.page.com/
www.page.com
page.com
page-10.com
1234.com
www.page`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}