import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}-\\d{2}-\\d{4})\\s?(\\d{2}:\\d{2})\\s?:([^:]+):((?:(?!\\d{2}-\\d{2}-\\d{4})[\\s\\S])+)";
final String string = "14-08-2015 14:18 : Example : Hello =) How are you?\n"
+ "What are you 2 doing?\n"
+ "14-08-2015 14:19: Example2 : I'm fine thanks!";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}