package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[a-zA-Z]{2}[_\-][a-zA-Z]{2})\/([^/#?]+)|(ea-access|[a-zA-Z]{3,}[^\/#?])`)
var str = `de-de/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}