$re = '/(\shref)\s*=\s*([\'"])/mi';
$str = '<ahref="example.com">
<a href="example.com">
<a href=\'example.com\'>
<a href ="example.com">
<a href =\'example.com\'>
<a href= "example.com">
<a href= \'example.com\'>
<a href = "example.com">
<a href = \'example.com\'>
<a href ="example.com">
<a href =\'example.com\'>
<a href= "example.com">
<a href= \'example.com\'>
<a href = "example.com">
<a HREF = \'example.com\'>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);