$re = '/^\d+(\.)?\d+/m';
$str = '12.00
.124
-.07
-65
124456
123423234.234234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);