import re
regex = re.compile(r"^(?!.*\b(?:dirty|rotten)\b).*?\b(?:red|green|yellow)\b.*\b(?:apple|peach|pear)\b.*$", flags=re.MULTILINE)
test_str = (" I have an green apple I have a yellow peach I have red and green apples\n\n"
"I have a dirty red apple I have a green peach that is dirty I have a yellow dirty apple\n\n"
"This is a green pear\n"
"This is a rotten green pear\n\n"
"This is pear, a green pear\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")