$re = '/(?<=AB[A-z0-9 -])[A-z0-9 -]/m';
$str = 'ABC123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);