import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\s)(([0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}|([0-9a-fA-F]{1,4}:){1,7}:|([0-9a-fA-F]{1,4}:){1,6}[0-9a-fA-F]{1,4}|([0-9a-fA-F]{1,4}:){1,5}(:[0-9a-fA-F]{1,4}){1,2}|([0-9a-fA-F]{1,4}:){1,4}(:[0-9a-fA-F]{1,4}){1,3}|([0-9a-fA-F]{1,4}:){1,3}(:[0-9a-fA-F]{1,4}){1,4}|([0-9a-fA-F]{1,4}:){1,2}(:[0-9a-fA-F]{1,4}){1,5}|[0-9a-fA-F]{1,4}:((:[0-9a-fA-F]{1,4}){1,6})|:((:[0-9a-fA-F]{1,4}){1,7}|:)|fe80:(:[0-9a-fA-F]{0,4}){0,4}%[0-9a-zA-Z]+|::(ffff(:0{1,4})?:)?((25[0-5]|2[0-4]\\d|1\\d{0,2}|[1-9]?\\d)\\.){3}(25[0-5]|2[0-4]\\d|1\\d{0,2}|[1-9]?\\d)|([0-9a-fA-F]{1,4}:){1,4}:((25[0-5]|2[0-4]\\d|1\\d{0,2}|[1-9]?\\d)\\.){3}(25[0-5]|2[0-4]\\d|1\\d{0,2}|[1-9]?\\d))(?=\\s|$)\n";
final String string = "{1: Initial address, regex should say valid/match}\n"
+ "2001:0db8:0000:0000:0000:ff00:0042:8329\n\n"
+ "{2: After removing all leading zeroes, regex should say valid/match}\n"
+ "2001:db8:0:0:0:ff00:42:8329\n\n"
+ "{3: After omitting consecutive sections of zeroes, regex should say valid/match}\n"
+ "2001:db8::ff00:42:8329\n\n"
+ "{4: The loopback address, regex should say valid/match}\n"
+ "0000:0000:0000:0000:0000:0000:0000:0001\n\n"
+ "{5: The loopback address be abbreviated to ::1 by using both rules, regex should say valid/match}\n"
+ "::1\n\n"
+ "{6: This should be valid, regex should say valid/match}\n"
+ "ABCD:ABCD:ABCD:ABCD:ABCD:ABCD:192.168.158.190\n\n"
+ "{7: This should NOT be valid/match}\n"
+ "::\n\n"
+ "{These two formats allows IPv6 applications to communicate directly with IPv4 applications, regex should say valid/match}\n"
+ "{8}\n"
+ "0:0:0:0:0:ffff:192.1.56.10\n"
+ "{9}\n"
+ "::ffff:192.1.56.10/96\n\n"
+ "{These next two formats are used for tunneling. It allows IPv6 nodes to communicate across an IPv4 infrastructure, regex should say valid/match}\n"
+ "{10}\n"
+ "0:0:0:0:0:0:192.1.56.10\n"
+ "{11}\n"
+ "::192.1.56.10/96\n\n"
+ "{These 4 should be valid/match}\n"
+ "{12}\n"
+ "::FFFF:129.144.52.38\n"
+ "{13}\n"
+ "::129.144.52.38\n"
+ "{14}\n"
+ "::FFFF:d\n"
+ "{15}\n"
+ "1080:0:0:0:8:800:200C:417A\n\n"
+ "{These 4 should NOT be valid/match}\n"
+ "{16}\n"
+ "::FFFF:d.d.d\n"
+ "{17}\n"
+ "::FFFF:d.d\n"
+ "{18}\n"
+ "::d.d.d\n"
+ "{19}\n"
+ "::d.d";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}