re = /(^|\s)(@.+?|https?.*?)($|\s)/
str = '@abcde ああああ https://t.co/aaa あああ
いいいい @abcde ssadsa
https://t.co/bbb うううう @abcde
sadw@dasdwdw
http://t.co/aaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end