$re = '/(?<=<val>)[^<]*/i';
$str = '<val>7.0.1081.3</val>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);