$re = '~^(?:(?:https?://)?(?:www|mobile|web|0)\.)?facebook\.com/(?:video\.php\?v=|.*?/videos/)(\d+)$~m';
$str = 'https://www.facebook.com/video.php?v=100000000000000
https://www.facebook.com/username1/videos/100000000000000
https://www.facebook.com/username2/videos/100000000000000
https://mobile.facebook.com/username2/videos/100000000000000
www.facebook.com/username2/videos/100000000000000
facebook.com/username2/videos/100000000000000
notfacebook.com/username2/videos/100000000000000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);