re = /(?:\d+\.\d+-)?\d+\.\d+.hz/m
str = ':2.400-2.483ghz;5.725-5.850ghz

transmissionpower(eirp),2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end