$re = '/(.)\1+/m';
$str = 'hiii, i love java soooo much';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;