import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bhttps?://(?!\\S+(?:jpe?g|png|bmp|gif))\\S+";
final String string = "http://test.com/index.html\n"
+ "https://anything.net/this\n\n"
+ "check out this link: https://anything.net/this it's really cool\n\n"
+ "https://anything.net/this it's really cool should match https://anything.net/this\n\n"
+ "https://anything.net/this and http://imgur.com/test/img.jpg\n\n\n"
+ "http://imgur.com/test/img.jpg\n"
+ "http://imgur.com/ixmas.jpg\n"
+ "http://example.com/testdirectory/rawr-gif.gif\n"
+ "testhttp://example.com/rawr\n"
+ "http://imgur.com/test/img.bmp\n"
+ "http://imgur.com/test/img.png\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}