$re = '/^(\w+) for \1/m';
$str = 'Apple for Apple
day for day
Money for Money';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);