package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bankit_bill_20[0-9][0-9]-(?:[1-9]|1[0-2]|0[0-9])-(?:[1-9]|1[0-9]|2[0-9]|3[0-1]|0[0-9])-[0-9]{2}_(?:abc|cde)[0-6]{0,2}\.csv\b`)
var str = `ankit_bill_2019-12-02-00_abc01.csv
ankit_bill_2019-12-02-00_abc.csv
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}