re = /(?<=span class="ope">).*?([a-zA-Z0-9]*\.(pl|com|net\.pl|tk|org|org\.pl|eu)).*(?=<\/span>)/
str = '<span class="ope">something[sometags] example.com</span>
<span class="ope">example.com something[sometags]</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end