$re = '/^\w+\.couleur\s?=\s?(vert|violet|orange)$/i';
$str = 'test.couleur = vert';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);