#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "'Target.*Write MBps\n(?:[\w; %\.]+,){9}([\w; %\.]+)"
Local $sString = "'Test Type,Test Description,,,,,,,,,," & @CRLF & _
"0,,,,,,,,,,," & @CRLF & _
"'Version,,,,,,,,,,," & @CRLF & _
"2006.07.27,,,,,,,,,,," & @CRLF & _
"'Time Stamp,,,,,,,,,,," & @CRLF & _
"2016-01-06 19:40:56:182,,,,,,,,,,," & @CRLF & _
"'Test Type,Test Description,,,,,,,,,," & @CRLF & _
"0,,,,,,,,,,," & @CRLF & _
"'Version,,,,,,,,,,," & @CRLF & _
"2006.07.27,,,,,,,,,,," & @CRLF & _
"'Time Stamp,,,,,,,,,,," & @CRLF & _
"2016-01-06 19:41:32:625,,,,,,,,,,," & @CRLF & _
"'Test Type,Test Description,,,,,,,,,," & @CRLF & _
"0,,,,,,,,,,," & @CRLF & _
"'Version,,,,,,,,,,," & @CRLF & _
"2006.07.27,,,,,,,,,,," & @CRLF & _
"'Time Stamp,,,,,,,,,,," & @CRLF & _
"2016-01-06 19:41:53:145,,,,,,,,,,," & @CRLF & _
"'Test Type,Test Description,,,,,,,,,," & @CRLF & _
"0,,,,,,,,,,," & @CRLF & _
"'Version,,,,,,,,,,," & @CRLF & _
"2006.07.27,,,,,,,,,,," & @CRLF & _
"'Time Stamp,,,,,,,,,,," & @CRLF & _
"2016-01-06 19:43:53:456,,,,,,,,,,," & @CRLF & _
"'Access specifications,,,,,,,,,,," & @CRLF & _
"'Access specification name,default assignment,,,,,,,,,," & @CRLF & _
"512B; 100% Read; 0% random,0,,,,,,,,,," & @CRLF & _
"'size,% of size,% reads,% random,delay,burst,align,reply,,,," & @CRLF & _
"209715712,100,100,0,0,1,0,0,,,," & @CRLF & _
"'End access specifications,,,,,,,,,,," & @CRLF & _
"'Results,,,,,,,,,,," & @CRLF & _
"'Target Type,Target Name,Access Specification Name,# Managers,# Workers,# Disks,IOps,Read IOps,Write IOps,MBps,Read MBps,Write MBps" & @CRLF & _
"ALL,All,512B; 100% Read; 0% random,1,1,1,0.571416,0.571416,0,114.283511,114.283511,0" & @CRLF & _
"MANAGER,A01030016NB,512B; 100% Read; 0% random,,1,1,0.571416,0.571416,0,114.283511,114.283511,0" & @CRLF & _
"PROCESSOR,CPU 0,,,,,,,,,," & @CRLF & _
"PROCESSOR,CPU 1,,,,,,,,,," & @CRLF & _
"PROCESSOR,CPU 2,,,,,,,,,," & @CRLF & _
"PROCESSOR,CPU 3,,,,,,,,,," & @CRLF & _
"WORKER,Worker 1,512B; 100% Read; 0% random,,,1,0.571416,0.571416,0,114.283511,114.283511,0" & @CRLF & _
"DISK,F:新增磁碟區,,,,,0.571416,0.571416,0,114.283511,114.283511,0" & @CRLF & _
"'Time Stamp,,,,,,,,,,," & @CRLF & _
"2016-01-06 19:44:21:973,,,,,,,,,,," & @CRLF & _
"'Test Type,Test Description,,,,,,,,,," & @CRLF & _
"0,,,,,,,,,,," & @CRLF & _
"'Version,,,,,,,,,,," & @CRLF & _
"2006.07.27,,,,,,,,,,," & @CRLF & _
"'Time Stamp,,,,,,,,,,," & @CRLF & _
"2016-01-06 19:45:17:785,,,,,,,,,,," & @CRLF & _
"'Access specifications,,,,,,,,,,," & @CRLF & _
"'Access specification name,default assignment,,,,,,,,,," & @CRLF & _
"512B; 100% Read; 0% random,0,,,,,,,,,," & @CRLF & _
"'size,% of size,% reads,% random,delay,burst,align,reply,,,," & @CRLF & _
"102912,100,100,0,0,1,0,0,,,," & @CRLF & _
"'End access specifications,,,,,,,,,,," & @CRLF & _
"'Results,,,,,,,,,,," & @CRLF & _
"'Target Type,Target Name,Access Specification Name,# Managers,# Workers,# Disks,IOps,Read IOps,Write IOps,MBps,Read MBps,Write MBps" & @CRLF & _
"ALL,All,512B; 100% Read; 0% random,1,1,1,1216.250748,1216.250748,0,119.36836,119.36836,0" & @CRLF & _
"MANAGER,A01030016NB,512B; 100% Read; 0% random,,1,1,1216.250748,1216.250748,0,119.36836,119.36836,0" & @CRLF & _
"PROCESSOR,CPU 0,,,,,,,,,," & @CRLF & _
"PROCESSOR,CPU 1,,,,,,,,,," & @CRLF & _
"PROCESSOR,CPU 2,,,,,,,,,," & @CRLF & _
"PROCESSOR,CPU 3,,,,,,,,,," & @CRLF & _
"WORKER,Worker 1,512B; 100% Read; 0% random,,,1,1216.250748,1216.250748,0,119.36836,119.36836,0" & @CRLF & _
"DISK,F:新增磁碟區,,,,,1216.250748,1216.250748,0,119.36836,119.36836,0" & @CRLF & _
"'Time Stamp,,,,,,,,,,," & @CRLF & _
"2016-01-06 19:45:30:673,,,,,,,,,,,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")