$re = '/^(\+(44|1|91|61))[0-9]+/';
$str = '+44143456';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);