$re = '/(^(0?[1-9]|[12][0-9]|3[01])[-]([a-zA-Z]+)[-]((19|20)\d\d))/';
$str = '29-Dec-2015';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);