$re = '/<a (?!data-link=)[^>]*>((?!<\/a>).*?)<\/a>/im';
$str = '<p><a data-link=\\"keepLink\\" href=\\"[1|9999|16|191967|256]\\">Daily Racing Link</a></p>\\r\\n<br>\\n <strong>OFFER – Get up to a £400 deposit bonus when you sign up with <a href="https://gateway.tracker.com/track-989">Fanduel</a>.</strong>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;