using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=embed\/)(.+?)(?=\?)";
string input = @"<iframe src=""//cdn.embedly.com/widgets/media.html?src=https://www.youtube.com/embed/e7zCqsjK1Vg?feature=oembed&url=http://www.youtube.com/watch?v=e7zCqsjK1Vg&image=https://i.ytimg.com/vi/e7zCqsjK1Vg/hqdefault.jpg&key=2aa3c4d5f3de4f5b9120b660ad850dc9&type=text/html&schema=youtube"" width=""600"" height=""338"" scrolling=""no"" frameborder=""0"" allowfullscreen="" style=""box-sizing: content-box; max-width: 100%; border: 0px;"" fr-original-style=""box-sizing: content-box; max-width: 100%; border: 0px;"" fr-original-class=""embedly-embed""></iframe>
<iframe src=""//cdn.embedly.com/widgets/media.html?src=https://www.youtube.com/embed/skLz87ixE48?feature=oembed&url=http://www.youtube.com/watch?v=skLz87ixE48&image=https://i.ytimg.com/vi/skLz87ixE48/hqdefault.jpg&key=2aa3c4d5f3de4f5b9120b660ad850dc9&type=text/html&schema=youtube"" width=""600"" height=""338"" scrolling=""no"" frameborder=""0"" allowfullscreen="" style=""box-sizing: content-box; max-width: 100%; border: 0px;"" fr-original-style=""box-sizing: content-box; max-width: 100%; border: 0px;"" fr-original-class=""embedly-embed""></iframe>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}