$re = '/(\d++|[-+*\/])/xm';
$str = '12+25*2/5
124 + 12 - 31
250 * 25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);