using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ar[.]";
string input = @"A garage is a good place to park a car.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}