$re = '/(?:http(?:s)?:\/\/)?(?:www\.)?(?:m\.)?(?:youtu\.be\/|youtube\.com\/(?:(?:watch)?\?(?:.*&)?v(?:i)?=|((?:embed|v|vi|user)\/)))([a-zA-Z0-9\-_]*)/i';
$str = 'Le site de Jack Cain : www.trylus.com La première hypnose de Laurent avec Jack : https://www.youtube.com/watch?v=3TkiIt0t6i8&fsfs (avancez 15 de minutes, le début n’est pas intéressant). Namasté Laurent]]>
https://www.youtube.com/watch?v=3TkiIt0t6i8 Vaisseaux, race extraterrestres, spiritualité…. quelle est l’histoire commune dans toutes ces hypnoses… ? https://www.Youtube.com/playlist?list=PL1eC1aP-LYNg2ya1ywPj0pipd0y2EWGEl
<iframe width="420" height="315"
src="https://www.youtube.com/embed/XGSy3_Czz8k">
</iframe> ';
$subst = "https://www.youtube.com/watch?v=$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;