use strict;
my $str = 'HHeelllloo';
my $regex = qr/.\K./p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";