const regex = /(\[.*?])|(\w+:.*?)\|(?=Description:)|(Description:.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[.*?])|(\\w+:.*?)\\|(?=Description:)|(Description:.*)', 'g')
const str = `[Testing.User]|Info:([Testing.Info]|Name:([System.String]|Matt)|Age:([System.Int32]|21))|Description:([System.String]|This is some description)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}