import re
regex = re.compile(r"^(0?[1-9]{1}|[1]{1}[0-7]{1})(\s|[-])?(y(\s?)o|yr([sz]?)|year([sz]?)((\s|[-])?(old)?)|y)((\s?|[-])(old)?)$", flags=re.MULTILINE)
test_str = ("10y\n"
"10yr\n"
"10yrz\n"
"10yrs\n"
"10 y\n"
"10 yr\n"
"10 yo\n"
"13 y o\n"
"09y\n"
"9y\n"
"09 y\n"
"9yr\n"
"9yo\n"
"9year\n"
"9 years old \n"
"9 yearz old\n"
"17 yo\n"
"17year\n"
"17 years\n"
"17 yearz\n"
"17-year-old\n"
"100years\n"
"13\n"
"10 your\n"
"18 yr\n"
"18yr\n"
"10 your\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")